GB/T 47014.4-2026 现行 国家标准

GB/T 47014.4-2026 工业通信网络 现场总线规范 类型2元素:EtherNet/IP,ControlNet和DeviceNet规范 第4部分:应用层协议规范

GB/T 47014.4-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP, ControlNet and DeviceNet specifications—Part 4:Application layer protocol specification

发布日期: 2026-01-28 实施日期: 2026-08-01 中国正版标准查询、采购、翻译等其他相关服务,请 联系我们
价格: $ 233.00
无货

基本信息

标准编号: GB/T 47014.4-2026
标准类型: 国家级标准
标准状态: 现行
is_force_gb: no
中国标准分类名称: 工业自动化仪表与控制装置
国际标准分类名称: 工业自动化系统
发布日期: 2026-01-28
实施日期: 2026-08-01
发布单位/组织: 国家市场监督管理总局、国家标准化管理委员会
归口单位: 全国工业过程测量控制和自动化标准化技术委员会(SAC/TC 124)
页数: 276 页

适用范围

1.1概述
现场总线应用层(FAL)为用户程序提供了一种访问现场总线通信环境的方法。在这方面,FAL能被视为相应的应用程序之间的一个“窗口”。
本文件为在自动化环境中的应用程序和特定于类型2现场总线的物资之间基本的时间严格和非时间严格的报文通信提供通用元素。“时间严格”是用来表示存在一个时间窗口,在这个时间窗口内需要以所规定的确定度完成一个或多个规定的动作。如果未能在该时间窗口内完成规定的动作,则会承受请求动作的应用的失败风险,且还会给设备、工厂甚至可能是人员生命带来附加风险。
本文件规定了远程应用之间的交互,并定义了由类型2现场总线应用层提供的外部可见行为,包括以下方面:
——正式的抽象语法,定义了在通信应用实体之间传递的应用层协议数据单元;
——传输语法,定义了适用于应用层协议数据单元的编码规则;
——应用上下文状态机,定义了通信应用实体之间可见的应用服务行为;
——应用关系状态机,定义了通信应用实体之间可见的通信行为。
本文件的目的是规定用于以下方面的协议:
——规定GB/T 47014.3—2026中界定的服务原语在网线上的表示;
——规定与其传输相关的外部可见行为。
本文件规定了类型2现场总线应用层协议,符合OSI基本参考模型(ISO/IEC 7498-1)和OSI应用层结构(ISO/IEC 9545)。
1.2规范
本文件的首要目的是规定应用层协议的语法和行为,该协议用于传递IEC 61158-5-2的应用层服务。
第二个目的是提供从以前存在的工业通信协议进行迁移的路径。
1.3一致性
本文件不规定单个的实现或产品,也不限制工业自动化系统中应用层实体的实现。一致性是通过实施该应用层协议规范来达到的。

研制信息

起草单位:

奥德威工业自动化技术服务(上海)有限公司、国能智深控制技术有限公司、机械工业仪器仪表综合技术经济研究所、电力规划总院有限公司、湖南科技大学、泾丰科技(深圳)有限公司、武汉东研智慧设计研究院有限公司、上海自动化仪表有限公司、重庆邮电大学、欧姆龙(上海)有限公司、罗克韦尔自动化(中国)有限公司、北京市自来水集团有限责任公司、北京市自来水集团大通供水技术有限公司、杭州德福线缆有限公司、广州虹科电子科技有限公司

起草人:

李韵、AlBeydoun、田雨聪、李冀颖、张晋宾、任军民、成继勋、赵勇、黄庆卿、朱镜灵、游和平、关鹏、高镜媚、王玉敏、王海城、张晨艳、周泽龙、吴亮红、陈秋苑、马建强、林燕芬

字数: 520 千字 页数: 276 页

同系列标准

引用标准

GB/T 41588.1-2022 道路车辆 控制器局域网(CAN) 第1部分:数据链路层和物理信令 GB/T 47014.1-2026 工业通信网络 现场总线规范 类型2元素:EtherNet/IP,ControlNet和DeviceNet规范 第1部分:数据链路层服务定义 GB/T 47014.2-2026 工业通信网络 现场总线规范 类型2元素:EtherNet/IP,ControlNet和DeviceNet规范 第2部分:数据链路层协议规范 ISO 639 ISO/IEC 7498-1 ISO/IEC/IEEE 8802-3 ISO/IEC 8824-1 ISO/IEC 8825-1 ISO/IEC 9545 ISO/IEC 10646 ISO/IEC 10731 ISO 11898-1 IEC 61158-1:2023 ISO/IEC 61158-5-2 IEC 61588:2021 IEC 61784-3-2 IEC 61800-7-202 IEC 62026-3:2014 IEEE Std 802.1Q-2018 IEEE Std 802.3-2018 IETF RFC 791 IETF RFC 1035 IETF RFC 1112 IETF RFC 1117 IETF RFC 1122 IETF RFC 1759 IETF RFC 2236 IETF RFC 2474 IETF RFC 2475 IETF RFC 2597 IETF RFC 2873 IETF RFC 3140 IETF RFC 3246 IETF RFC 3376 IETF RFC 4594 GB/T 47014.3-2026 工业通信网络 现场总线规范 类型2元素:EtherNet/IP,ControlNet和DeviceNet规范 第3部分:应用层服务定义

采用标准

IEC 61158-6-2:2023

相关标准

联系我们