GB/T 47014.4-2026 Active National standards

GB/T 47014.4-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP, ControlNet and DeviceNet specifications—Part 4:Application layer protocol specification

GB/T 47014.4-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP, ControlNet and DeviceNet specifications—Part 4:Application layer protocol specification

Publish Date: 2026-01-28 Implement Date: 2026-08-01 For services related to genuine standard inquiry, procurement, translation, and other related services in China, please Contact Us
Price: $ 233.00
Out of stock

Basic Information

Standard Code: GB/T 47014.4-2026
Standard Type: National standards
Standard Status: Active
is_force_gb: no
CCS Name: Industrial automation instrumentation and control devices
ICS Name: Industrial automation systems
Publish Date: 2026-01-28
Implement Date: 2026-08-01
Pages: 276 pages

Scope

1.1 Overview
The Fieldbus Application Layer (FAL) provides a method for user programs to access the Fieldbus communication environment. In this regard, FAL can be regarded as a "window" between corresponding applications.
This document provides common elements for time-critical and non-time-critical message communication between applications in an automation environment and Type 2 Fieldbus-specific devices. "Time-critical" refers to the existence of a time window within which one or more specified actions must be completed with a specified degree of certainty. If the specified actions cannot be completed within this time window, there is a risk of failure for the application requesting the actions, and this could also pose additional risks to equipment, factories, and even human lives.
This document specifies the interaction between remote applications and defines the externally visible behavior provided by the Type 2 Fieldbus application layer, including the following aspects:
—— Formal abstract syntax, which defines the application layer protocol data units exchanged between communication application entities;
—— Transport syntax, which defines the encoding rules applicable to application layer protocol data units;
—— Application context state machines, which define the externally visible application service behavior between communication application entities;
—— Application relationship state machines, which define the externally visible communication behavior between communication application entities.
The purpose of this document is to specify the protocol used for the following:
—— Specifying the representation of service primitives defined in GB/T 47014.3—2026 on the network;
—— Specifying the externally visible behavior associated with their transmission.
This document specifies the Type 2 Fieldbus application layer protocol, which complies with the OSI Basic Reference Mo

Development Information

Word Count: 520 Thousand words Pages: 276 pages

Same series standard

Referenced Standards

GB/T 41588.1-2022 Road vehicles—Controller area network (CAN)—Part 1:Data link layer and physical signalling GB/T 47014.1-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 1:Data-link layer service definition GB/T 47014.2-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 2:Data-link layer protocol specification ISO 639 ISO/IEC 7498-1 ISO/IEC/IEEE 8802-3 ISO/IEC 8824-1 ISO/IEC 8825-1 ISO/IEC 9545 ISO/IEC 10646 ISO/IEC 10731 ISO 11898-1 IEC 61158-1:2023 ISO/IEC 61158-5-2 IEC 61588:2021 IEC 61784-3-2 IEC 61800-7-202 IEC 62026-3:2014 IEEE Std 802.1Q-2018 IEEE Std 802.3-2018 IETF RFC 791 IETF RFC 1035 IETF RFC 1112 IETF RFC 1117 IETF RFC 1122 IETF RFC 1759 IETF RFC 2236 IETF RFC 2474 IETF RFC 2475 IETF RFC 2597 IETF RFC 2873 IETF RFC 3140 IETF RFC 3246 IETF RFC 3376 IETF RFC 4594 GB/T 47014.3-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 3:Application layer service definition

Adopt standards

IEC 61158-6-2:2023

Related Standards

Contact Us