GB/T 47014.2-2026 Active National standards

GB/T 47014.2-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 2:Data-link layer protocol specification

GB/T 47014.2-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 2:Data-link layer protocol specification

Publish Date: 2026-01-28 Implement Date: 2026-08-01 For services related to genuine standard inquiry, procurement, translation, and other related services in China, please Contact Us
Price: $ 281.00
Out of stock

Basic Information

Standard Code: GB/T 47014.2-2026
Standard Type: National standards
Standard Status: Active
is_force_gb: no
CCS Name: Industrial automation instrumentation and control devices
ICS Name: Industrial automation systems
Publish Date: 2026-01-28
Implement Date: 2026-08-01
Pages: 408 pages

Scope

1.1 Overview
The data link layer provides basic time-critical message communication between devices in an automated environment.
This document specifies the main protocol with the following characteristics:
—— This protocol provides communication opportunities for all participating data link entities in a sequential, cyclic synchronous manner. Foreground scheduling access can be used for time-critical activities, while background unscheduled access can be used for non-time-critical activities.
—— It provides deterministic and synchronized transmission with a cycle interval of up to 1 ms for devices separated by a distance of 25 km. While normal operation continues, this performance can be dynamically and online adjusted by reconfiguring the parameters of the local link. Similarly, DL connections and new devices can be added or removed during normal operation.
—— This protocol provides a method of maintaining clock synchronization with an accuracy of better than 10 μs across the entire extended link.
—— This protocol optimizes the data transmission efficiency of data link entities actively acquiring multiple data streams by concatenating multiple DLSDUs and related DLPCIs into a single DLPDU.
—— The maximum system scale is an unlimited number of 99 nodes, each with 255 DLSAP addresses. Each link has up to 2^24 associated peers and publishers DLCEPs.
This document specifies additional lower-layer protocols or implementations of additional lower-layer protocols used in conjunction with ISO/IEC/IEEE 8802-3.
This document specifies a corresponding set of objects that provide a consistent management interface for the lower layer.
1.2 Specifications
This document specifies:
a) The procedures for timely transmission of data and control information from a data link user entity to a peer user entity, and among data link entities that form a distributed data link service provider;

Development Information

Word Count: 780 Thousand words Pages: 408 pages

Same series standard

Referenced Standards

GB/T 47014.1-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 1:Data-link layer service definition GB/T 47014.4-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP, ControlNet and DeviceNet specifications—Part 4:Application layer protocol specification ISO 11898-1:2015 ISO/IEC 7498-1 ISO/IEC 7498-3 ISO/IEC 13239 ISO/IEC/IEEE 8802-3 IEC 61131-3 IEC 61588 IEC 61784-3-2 IEC 62026-3:2014 IEC 62439-3:2016 IEEE Std 802.1AB-2016 IEEE Std 802.1ABcu-2021 IEEE Std 802.1Q-2018 IEEE Std 802.3-2018 IETF RFC 951 IETF RFC 1213 IETF RFC 1542 IETF RFC 1643 IETF RFC 2131 IETF RFC 2132 IETF RFC 2863 IETF RFC 3418 IETF RFC 3635 IETF RFC 4541 IETF RFC 5227:2008 GB/T 47014.3-2026 Industrial communication networks—Fieldbus specifications—Type 2 elements:EtherNet/IP,ControlNet and DeviceNet specifications—Part 3:Application layer service definition

Adopt standards

IEC 61158-4-2:2023

Related Standards

Contact Us